eightolives.com


Home Products Services Docs Support

eightolives' WaveformViewer Quick Hints

WaveformViewer is tested using Firefox, Safari and Chrome browsers.

When you first start WaveformViewer, a splash screen and demonstration waveforms are displayed. To clear these waveforms, your first action should be to press the green ESC button. Any other action will retain the waveforms for your use. To delete the waveforms at any time, select menu option Edit > Delete All.

All actions only use left mouse clicks or touches.

Use the + and - buttons in the left column to zoom

Use the < and > buttons in the left column to pan left or right

The green ESC button terminates the current state or operation returing to "idle state".

Clicking or touching unused diagram area will close any open menus.

To load a timing diagram example:

File > Open Project - select the Server service then select a project
Design > Open Project File - select the ".vcd" file to open then click the Open button

To add signal, click menu Edit > New Signal

Clicking or touching a signal's display area moves the active cursor to that spot and selects the signal.

Click the Cursor 1 or Cursor 2 button to select the active cursor.

To add annotations or timing constraints, select menu Pref > Show Annotations
Click Cursor 1 on the edge of the first signal and then click Cursor2 puting it on the edge of the second signal.
Click the Constraint button to get the Constraint Editor popup.
Fill in the inforation and click the Update Constraint button.
Edit > Edit Constraints to edit constraints later.

To load a simulation example:

File > Open Project - select the Server service then select a project
Design > Open Project File - select the ".js" file to open then click the Open button
If a design has loaded, its name will appear in below the time line.
Design > Open Project File - optionally select the corresponding ".vcd" file to open then click the Open button

To run a simulation;
Load the .js model, then click File > Check Simultable
If OK, the typical sequence to run a sim is:
1. Restart button (<<)
2. Load VCD button (v)
3. Run button (>>)

To save your data to Local Project (your browser's cache):

File > Open Project - select the LOCAL service (which only supports Local Project)
File > Save Project - this saves your vcd file to cache. If there are constraints defined, a .json file is also saved.

To save your data to your computer's file system (if available):

File > Save VCD (FS)

To save your data to an External Service such as an eightolves Microserver operating on your local network:

File > Open Project - select External Service
Configure External Service by specifying its URL or use Discovery Start to search for active local servers. If a server is found, click on the displayed item which enters its URL and then click OK. You may be prompted for login information.
File > Open Project - select the desired project
File > Save Project - this saves your data to the project

To save your data to Google Drive:

File > Open Project - select Drive
You may be asked to log in to Google Drive. If so the Google login window will appear.
When you are successfully logged in, "Google Drive" will appear as the project name.
File > Save Project - this saves your data to the project

Start WaveformViewer

Open Issues

Report an Issue