eightolives.com
_)?  Reentry

2“7 An Overview of the Double Entry Accounting Tool
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The eightolives' Reentry tool provides a double entry record
keeping system implemented in Java. It runs wherever Java runs.

You use it for:

« Tracking your personal finances
 Managing a small business finances
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Why use Reentry?

« Keeping track of finances using double entry
accounting captures your financial lifestyle for
purposes of analysis, planning and reporting
taxes

* Analysis of account data may provide insight for
beneficial change

» Use historical data for budgeting
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Start the tool from the Reentry Home Page

B
;Eile Edit Wiew Go Bookmarks IW
- B?Ek - @ - Rg‘ad d& http:/fwww eightolives . comjdocs/Reentryfindex htm w

i Th Home | Wk Bookmarks £ mozilao ozillaZine £ mozdev.org

Reentry
1. Subscribe or

eightolives.com
g
Tools Tutorials Templates and Guidelines Techneology Services Store Support
Home

Buy - Become a

Registered User Getting Started

2. Install

Reentry is a double

3. Login and
Start Reentry

Click to run

entry accounting tool
targeted for personal or
small business use. Use
it to manage your
checkbook, track
expenses in appropriate
accounts, and produce
reports. Store data on
your computer as XML
files or

DES encrypted files.

% E 2 E3
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password-protected,

Reentry is a Java program that runs on whatever platform Java can run. It

http://www.eightolives.com/docs/Reentry/index.htm
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Money Is tracked in a set of ACCOUNTS

« ASSETS are things you own

AcCcount Viewer - New_Project

° Checklng Account File View Report Preferences Help |
B Account Wiewer 2
« Savings Account ¢ ¥ HowProfec [ccount Summary
° Cal’, home, cash k[:' SW;:*’:W“”T %lz‘lg%kénggﬂmccmnt Balance:
¢ sets : .
« LIABILITIES are things you owe *S curent st | Accounts payaie: $47.00
o mvestments
o Accounts Payab|e (bl”S) - D. Invertory working Capital: $32353.01
\?E Liakilities and Met Worth | Assets $82599.99
« Mortgage, Loans v O Liabilities 1. |
o[ Current Liahilities ]%lsaggg;e%gnd Equuty (et Worth):
« Net Worth (or Equity) represents the wt @ Netdorn |
3 stoc | Liabilities: $146.99
sum of your riches _— & onemnosas ||
. 0 Retained Earnings Equity{Met Worth): §82453.00
« Income and (Expenses) are also detailec b income
in th'S Category o[ (Expenses)

Clicking an account folder displays its value.
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A TRANSACTION makes Money flow

between ACCOUNTS 1

For example, when you receive wages
(income is in Net Worth), you put it in
your checking account (an asset).

When you buy an item ( inventory is an
Asset) you charge your Credit Card
(Liability)

When you get the bill, the Credit Card
account (Liability) decreases and
Accounts Payable (Liability) increases.

When you pay the bill, Accounts Payable
(Liability) decreases and Checking
Account (Asset) decreases.

Copyright © 2010 William Kaupinis All Rights Reserved

>

LIABILITIES +
NET WORTH
—— (or EQUITY)

ASSETS

* |n Double Entry
accounting the value of
ASSETS always equals
the value of LIABILITIES
+ NET WORTH

« Each Transaction affects
at least two accounts so
that the balance can be
maintained 6
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File View Operations Preferences Help

Tool bar buttons invoke dialogs

for the mOSt frequent funCtiOnS. iew an Account Record a Purchase |/ Eill Pay a Eill Record a Sale Receive Payment
_ ome | Checking Account | Inventory | Credit
The Home Tab displays the tree [ __
structure of the accounts. Sl e ee e Rusiec,
. . . File Yiew Report Preferences Help
Accounts are viewed in detail in P ——— ;
other tabs. ¢ » |Account Summary
o B Accounts
. . ¢ O Root Account | Checking Account Balance:
Accounts are organlzed INto o (3 Assets | $2000.00
two gI’OUpS: @ Current Assets Accounts Payable: $47.00
[ Investments
. Assets | o [?ia;:::\?ensmaﬁn,d _ Working Capital: $32352.01
* Liabilities + Net Worth (Equity) > o Lanites | ssets: $82599.99
b G Current Liabilities | Liabilities and Equity (et Worth):
| $82599.99
The value of Assets are always ¢ @ Net worh
equal to the value of Liabilities = stoek |isbilities: $14€.99
+ Net Worth. ©1' Opening Balances | Equity(Net Worth): $82453.00

(1 Retained Earnings

o[ Income

Any transaction affecting one > (Expenses)
account is always balanced by
an affect on another.

Copyright © 2010 William Kaupinis All Rights Reserved Right Clicking folders gives you OptiOﬂS to view

and edit the account tree. 7
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You can start a New Project from the menu option File > Start a New Project
Or you can select a starting template or open other related files
Or you can select a demonstration example from the Help Browser

I -J"

File|\-fie Opfrations Preferences Help

Open ﬁE¢DU"I Template ] | Receive Payment| ‘ Edit Transal:tiun|
Open File
Open URL

Open;up:ffmw.r.eightnlives.cumfdm:sfReemwfducsfPersunal_Demu.xml

] HTML Viewer
File Go Help

Start 4 Mew Project...

Commit
| 5% &’
Exit -
7 B Accounts : ] _ iah
b B3 Root Account Checking Account: $2000.00 eightc
¢ [ Assets | Accounts Payable: $47.00
o= [ Current Assets i _ _ Reentry
{|wWorking Capital: $32253.01 _
o[ Investments : & Quick Start Example: A Personal Accounts Example
@ inventory | Assets: $82599.99
¢ [0 Liabilities and Met Warth : Overview

o Liahilities and Equity et Worth):
T D Liahilities $8259999

o= C t Liabiliti
= Current Liabilties | eLiabilities: $148.99
¢ [0 Met worth : ® Equityet Worth):
@ stock $82453.00

Feantryis intended to operate on one project or set of acce
session. lnthe Home tab's Account Viewer window, the aco
orgainized in afolder wiew tree structure with two main brs
and Liakilities, Clicking on any folder displays a summary o

at that laval Riaht ~lickina an itarm Aicklave o rer—nim Foann
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New Project Name: [MNew_Project| |

Select Storage Location

eightolives.com

@ Store as Files in Directory Select Directory

| O Encrypt

i) Store in Database -

Select Starting Account Structure

) eightolives Personal Template

@ pightolives Business Template

Other Information

Author: |

Cupyﬂght|

Save and Open Project Cancel
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When you start a new
Project, you are asked
to select a directory in
which to put all the
data files.

Then select the basic
starting template of
accounts.
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File View Operations Preferences Help

The Accounts are loaded into a |Vlew an Account| | Record a Purchase / Bill| | Pay aBill| | Record asale| | Receive Payment |
tree structure display. You can Home [ Checking Account (SN (N Peuy Cash | Inventory | Credit
add or delete accounts by right | |
clicking accounts in the tree ':";E E‘;‘;:W:;Zf“ Ereferences Help
display. PN Account Summary

. .. . ? ': gcn':z:t Account Checking Account Balance:
Right clicking a primary account ¢ @ Assers |#2000.00
lets you open that account in ‘:g e fuas Accounts Payable: $47.00
detail in a separate tab. & imemory | Working Capital: $32353.01

¢ @ Liabi-litie.s- fand Net Worth pssets: $82599 99

Summary Accounts are folders et | " ——————
that contain other accounts. You ? B3 Net worth |P6259990
can not involve a transaction on a g e bt [Hapnues: $146.99
Summary Account. B2 Retsined Eamings | | et Worthl: §52453.00

o1 Income
o~ [3 (Expenzes)

Actual data (accounts,
transactions) are only saved to a
file when you execute Commit
either from a button or menu

option. Accounts can only be deleted if their value is 0.00

Copyright © 2010 William Kaupinis All Rights Reserved
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The Menu option View > Run a Script

gives you other display and function options
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 The View Account
button lets you easily
select which account
you would like to view
INn more detalil In a
separate tab.

* Right clicking an
account in the

account tree also
gives you that option
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Detail View of Accounts Payable

. -]

File View Operations Preferences Help

‘ View an Accnunt‘ ‘ Record a Purchase | Bill| | Pay a Bill‘ | Record a Sale| ‘ Receive Payment| ‘ Edit Transaclinn|
Checking Account || i Petty Cash | Inventory | Credit Card | Accounts Fayable Phone

Accounts Payable
File Operations Help

Date Transaction 1D Diescription Amount Balance Feference E.eflD Camment Closed Task
10407 10 1286427829356 Sears Wacuum a5 99 95 99 Inwentary 1286427821176 PalD
1ojo7 10 1286437831176 Sears Yacuum -99.99 0.00 Credit Card 12B6437E82935¢6 PO
1007 10 1286427880478 W erizon 47.00 47 00 Phane 0

A T \3

Matching Account

Transaction ID Amount Reference Transaction ID
Positive Value = amount owed

Negative value = amount paid

Transaction Date

Add a New Entry Button

Current Total

Commit Data to
Tutal\éoo || Add New Enuy || Commit |‘ Database Button

Welcome to Reentry

Copyright © 2010 William Kaupinis All Rights Reserved
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File %Yiew Operations Preferences Help

Yiew an Account Record a Purchase | Eill Pay a Bill Record a Sale Receive Payment Edit Transaction

Checking Account || Petty Cash |f Inventory | Credit Card ﬁﬁ

Checking
File Operati Check: | |

Feference
Date: | 12/2/10 | Opening Balances

Transaction 1D:

Description: |Star1ing Balance |

Payment | |

Deposit: | 2000.00 |

Complete: | |

Balance: |

atching Account: |Opening Balances -

RefID: | |

Comment: | |

Task: | |

Add Entry Cancel
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Hints

« Dollar amounts are expressed as d.cc (e.g. 13.99)
where

« d are digits representing dollars

« C are digits representing cents (2 digits after decimal
point)

« Dates are expressed as mm/dd/year: 01/12/2010

« Use the “Record a Purchase / Bill” button when
you buy something or receive a bill

« Use the “Pay a BIll” button when you pay a bill

Copyright © 2010 William Kaupinis All Rights Reserved
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Typical Account Pairs

* When first initializing accounts:

- Account 1 = Checking Account
- Account 2 = Opening Balances

* Getting a BiIll

- Account 1 = Accounts Payable
- Account 2 = Credit Card or an Expense item such as Phone

* Buying Something with Cash

- Account 1 = Inventory item or an Expense such as Gasoline
- Account 2 = - Petty Cash

Copyright © 2010 William Kaupinis All Rights Reserved
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Privacy Considerations

* Privacy issues exist when people's names are
associated with Social Security numbers or
credit card or bank account numbers

e Laws regarding privacy issues vary between states

« Strongly recommend you avoid the keeping of
Social Security, credit card or bank numbers in

the Reentry databases.

Copyright © 2010 William Kaupinis All Rights Reserved
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Files saved by Reentry

« ReentryProperties.ini — your preferences, history
* ProjectName_project.xml — defines links to project files
* ProjectName_accounts.xml — account structure for this project

* ProjectName_transactions.xml — actual transactions recorded

 For businesses:
* ProjectName_customers.xml — key customer data
* ProjectName_products.xml — products, costs, prices

* ProjectName_sales.xml — record of sales information

« Data is saved with the files listed above and a copy with an appended time stamp to
permit “going back in time” views and data backup.

Copyright © 2010 William Kaupinis All Rights Reserved
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Security

« Financial data is normally treated as sensitive data.
You do not normally give others access to this
iInformation

« Reentry files may be stored as either unencrypted or
encrypted.

« Unencrypted files can be viewed in any text editor
« Encrypted files require a password to access the data

 When data is stored in network databases, use the
secure “https” protocol for database communication

Copyright © 2010 William Kaupinis All Rights Reserved
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File VYiew Operations Preferences Help e I g hto I Ives [ CO m
View an Account Record a Purchase [ Eill Pay a Bill Re E n C r ti O n
_--T.T yp
oL R
S
vl OK Cancel
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B AcCcounts H

* You can select to encrypt your data when you
use the “File > Start a New Project” dialog

* Reentry uses password protected DES
encryption

* Encrypted files are stored with filename suffix
“.eml”

* Don't forget your password or you will be
unable to access your data!

Copyright © 2010 William Kaupinis All Rights Reserved
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Using the Business Template

* Use of the Business Accounts template Is
similar but Inventory Is a summary account
made up of Raw Materials, Work In Process
and Finished Goods

 Product, Customer and Sales databases are
also used

* See a separate tutorial on applying Reentry for
business

Copyright © 2010 William Kaupinis All Rights Reserved
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For more information

e Check the tutorials at:
nttp://www.eightolives.com/tutorials.htm

« Review bug reports and status from the Reentry home
page at:

nttp://www.eightolives.com/docs/Reentry/index.htm

Copyright © 2010 William Kaupinis All Rights Reserved
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