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Abstract

The Workspaces Desktop toolset has the RequirementsTracker 
tool that can be deal with a project’s Requirements, 
Requirements Review, Design Document, Verification Plan and 
Verification Report.  This tool helps you create and manage 
requirements and other key documentation for a design.

Documents can contain links to the design and document 
templates which semi-automate the creation and retrieval of 
these items. Links can also support traceability of requirements 
to the design and its verification.
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Things You Can Do

● Capture the Requirements.
● Three methods exist for requirements management in Workspaces

– 1. Import requirements from a .txt file [or .htm file] 

– 2. Import requirements from a Word document via HTML

– 2. Create requirements from a new or existing design

– 3. Create new requirements from scratch (starting with a template)
● Review the Requirements.
● Associate Requirements with the Design.
● Create the Design Description (aka Design Implementation Document)
● Create the Verification Test Plan.
● Create simulation tests.
● Create Verification Report.
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Importing a Text File

● The text file must be formatted so that a line 
with a number or number.number item followed 
by words is the paragraph number and title 
such as:

1.0 Scope
2.0 Applicable Documents
3.0 Requirements
3.1 Item Description

● Stuff between the paragraph number/title lines 
is the text

● Limitations of text file import:
● Figures, URLs, formatting info and tables 

are lost or obfuscated unless html notation 
is used i.e. “<table><tr><td>First column</
td></tr></table>”

● Text lines that start with a number may be 
misinterpreted as a new paragraph 
number / title

● Tabs and other non-printing characters 
may cause difficulties

Example:

1. Scope
This is a demo text file that may be imported into the 

Requirements Tracker tool.
2. Applicable Documents
Although you can list applicable documents however 

you wish, the tool provides ways to enter and 
manage the applicable documents list so they can 
be referenced for traceablity.

3. Requirements
3.1 Item definition
This is a description paragraph. You can reference a 

figure or add formatting data using basic HTML 
notation. For example see the block diagram of 
<img src="./block.png">Figure 1</a>.

3.2 More stuff
The item shall have more stuff as described in Table 

1.<table border="1"><tr><th>Item</th> 
<th>Description</th></tr> <tr><td>Color</td> 
<td>Red</td></tr></table>

4. Quality Assurance Provisions
5. Preparation for Delivery
6. Notes
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Importing an HTML File

● HTML files may be read.
● Headings- h1, h2, h3 etc – are 

interpreted as containing 
paragraph number and title

● The rest is interpreted as spec 
data

● Limitations of HTML import
● Bug in exporting to .xml version
● Other non-essential HTML tags 

are retained, sometimes affecting 
readability

Example:

<html>
<body>
<h1>1. Scope</h1>
<p>This is a demo HTML file that may be imported into the 

Requirements Tracker tool.
</p>
<h1>2. Applicable Documents</h1>
<p>Although you can list applicable documents however you wish, 

the tool provides ways to enter and manage
the applicable documents list so they can be referenced for 

traceablity.
</p>
<h1>3. Requirements</h1>
<h2>3.1 Item definition</h2>
<p>This is a description paragraph. You can reference a figure or 

add formatting data using basic HTML notation. For example
see the block diagram of <img src="./block.png">Figure 1</img>.
</p>
<h2>3.2 More stuff</h2>
<p>The item shall have more stuff as described in Table 1.
</p>
<table border="1"><tr><th>Item</th><th>Description</th></tr>
<tr><td>Color</td><td>Red</td></tr></table>
<h1>4. Quality Assurance Provisions</h1>
<h1>5. Preparation for Delivery</h1>
<h1>6. Notes</h1>
</body>
</html>
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Example of the .xml database

<?xml version="1.0"?>

<requirements_document>
<title>example, ,, ,, ,, ,,,,,,</title>
<second>imported from D:\Documents and Settings\kaupinw\My Documents\a2\example.htm</second>
<cover><br></br></cover>
<item id="0"><rqt>1.</rqt><desc>Scope</desc><from> </from><to> </to><text><p>This is a demo HTML file that may be imported 

into the Requirements Tracker tool.</p></text><method>N</method><evidence> </evidence><comment> </comment><val> 
</val><reviewed> </reviewed><critical> </critical></item>

<item id="1"><rqt>2.</rqt><desc>Applicable Documents</desc><from> </from><to> </to><text><p>Although you can list applicable 
documents however you wish, the tool provides ways to enter and manage the applicable documents list so they can be referenced 
for traceablity.</p></text><method>N</method><evidence> </evidence><comment> </comment><val> </val><reviewed> 
</reviewed><critical> </critical></item>

<item id="2"><rqt>3.</rqt><desc>Requirements</desc><from> </from><to> </to><text></text><method>N</method><evidence> 
</evidence><comment> </comment><val> </val><reviewed> </reviewed><critical> </critical></item>

<item id="3"><rqt>3.1</rqt><desc>Item definition</desc><from> </from><to> </to><text> <p>This is a description paragraph. You can 
reference a figure or add formatting data using basic HTML notation. For example see the block diagram of <img 
src="./block.png">Figure 1</img>.</p></text><method>N</method><evidence> </evidence><comment> </comment><val> 
</val><reviewed> </reviewed><critical> </critical></item>

<item id="4"><rqt>3.2</rqt><desc>More stuff</desc><from> </from><to> </to><text><p>The item shall have more stuff as described in 
Table 1.</p><table 
border="1"><tr><th>Item</th><th>Description</th></tr><tr><td>Color</td><td>Red</td></tr></table></text><method>N</method>
<evidence> </evidence><comment> </comment><val> </val><reviewed> </reviewed><critical> </critical></item>

<item id="5"><rqt>4.</rqt><desc>Quality Assurance Provisions</desc><from> </from><to> 
</to><text></text><method>N</method><evidence> </evidence><comment> </comment><val> </val><reviewed> 
</reviewed><critical> </critical></item>

<item id="6"><rqt>5.</rqt><desc>Preparation for Delivery</desc><from> </from><to> 
</to><text></text><method>N</method><evidence> </evidence><comment> </comment><val> </val><reviewed> 
</reviewed><critical> </critical></item>

<item id="7"><rqt>6.</rqt><desc>Notes</desc><from> </from><to> </to><text> </text><method>N</method><evidence> 
</evidence><comment> </comment><val> </val><reviewed> </reviewed><critical> </critical></item>

</requirements_document>
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Importing Requirements from Word (1 of 2)

● Using Word, read in the .doc 
or .rtf file 

● From the Change Tracking 
Toolbar pulldown menu, 
Accept All Changes

● All paragraph numbers and 
titles should have a Heading 
style (i.e. H1 – H6)

● From the File > SaveAs 
menu 

● Select HTML (Filtered) as the 
type
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Importing Requirements from Word (2 of 2)

● In Workspaces select Command Processor 
from the Application Menu

● In Command Processor, select File > Load 
Library Script and then select 
RqtsFilterScript.js

● The script will open an edit window 
results.txt which should be reviewed and 
then saved

● Open the Requirements Tracker tool and 
File>Open File the saved results.txt

● Review the imported document and then 
File > Save as > Save Database as .xml

● Save it as: 
designname_requirements.xml and 
save it in the designname\doc directory
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Creating Requirements from a Design

● In the Workspaces Design Tool, File > Import the top level VHDL file
● Right click the top element and select Make New > Document > 

Requirements Document
● In the Requirements Tracker tool, File > Save As > Save Database as 

.xml
● Save in the doc directory: doc\DesignName_requirements.xml
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RequirementsTracker has 3 Primary Views

Click for 
Document View

Click to Invoke
Requirements
From Workspaces

Click for 
Editor View

Click for 
Matrix View

Document
View shows 
the HTML 
view
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Matrix View Can Display Various Status

Create traceability and compliance matrices and “shall” tables.
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Editor View for editing
Select an item 
in the tree.

Edit fields in 
the text boxes

Select the 
verification 
method.

Define 
Traceability to 
Applicable 
Documents

Identify as 
safety critical 
or not.

TBDs are 
highlighted in 
red

Update, insert or delete Review the 
requirement
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Review each “shall” requirement

This Review Checklist highlights things that make a requirement “good”.



  14

eightolives.com

Copyright © 2010 William Kaupinis All Rights Reserved 

Click for a Requirements Review
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Other Features

• Start new documents using various 
templates.
• Compare different versions of the rqts 
for differences
• Merge new versions of the rqts with an 
existing one

• Set Document Title / subtitle
• Set the critical flags to a default
• Set a default for traceability
• View and edit the Applicable Documents list
• Add new Applicable Documents
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Edit > Acronyms
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Edit > Applicable Documents
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Use DesignTool to Create Documents With 
Design Data

● You can create a Design Description template
● Once you create a Requirements Document for 

your project you can create a Verification Plan 
template with all requirements (“shalls”) 
itemized and linked to the Requirements 
Document

● Once you have a Verification Plan, you can 
create a Verification Report template
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Right Click on the Top Design Element

Make New > Document > Verification Test Plan
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Fill in the “plan” details for each item

● The Verification Plan has sections for 
Inspection, Analysis, Simulation, Test, 
Demonstration, Similarity and 
Certifications.

● “Shalls” to be verified are itemized.
● Edit the document to allocate 

Simulation Shalls to a testbench test 
and add a comment about how the 
shall should be simulated.

● Save the Database in the doc directory
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Create a Verification Report

● Once you have Requirements and a Verification Test 
Plan, you can create a Verification Report
● In the Workspaces DesignTool, right click the element and 

Make New > Document… > Verification Report

● Select Preferences and enable the following to show data 
in the report:
● Show Comments
● Show Rqt Verified (shows in matrix view only)
● Show Evidence
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Explain compliance in the Comment Field
Text field contains the Requirement
Comment field explains compliance 

Enter a link to 
evidence.

Evidence 
button gets 
link from 
Applicable 
Documents.

Click the 
Verified 
Checkbox.

File > Save As to save the data.
Update Local to save data in memory. 
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End Notes

● Printing may unfortunately result with larger than 
expected font sizes
● You can save the files in HTML (.htm) format and then post-

process them in your favorite editor for nicer printing

● Matrix views and “Shall Tables” can also be saved as 
a .xls file which is readable by Microsoft Excel

● Remember that the “Update Local” button updates 
memory only
● Use the menu option File > Save As to store your data in a 

file.
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For more information
● Check the tutorials at: 

http://www.eightolives.com/tutorials.htm
● Workspaces Desktop Tool Overview

● Checkout some of the document templates at: 
http://www.eightolives.com/templates.htm

● Read the Workspaces Desktop Users Manual

http://www.eightolives.com/tutorials.htm
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